You can skip this in seconds

Click here to continue

Excelsior Installer 1.8

What's Required in Version 1.8 of Excelsior Installer

CPU: Intel Pentium II; RAM: 128 MB minimum; Disk Space: 34 MB

What's New in Version 1.8 of Excelsior Installer

NSIS integration. Excelsior Installer is now able to build your setup package with NSIS. You may use Excelsior Installer as a GUI front-end for NSIS or use this feature to migrate your project to NSIS whenever necessary.

Look for Similar Items by Category

Feedback

Popular Downloads